Problems with th GUI (SOLVED – August 2019)


Join XMapTools Forums XMapTools FAQ Problems with th GUI (SOLVED – August 2019)

Tagged: 

This topic contains 2 replies, has 2 voices, and was last updated by  Pierre Lanari 2 weeks ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #1625

    anthnyrs
    Participant

    I installed XMapTools, but when I run the GUI, the interface doesn’t work properly, it mostly a blank window with some of the buttons. In the MatLab command window it shows messages saying Exception in thread “AWT-EventQueue-0” java.lang.NullPointerException, and more like this one. Do you know what is happening?

    #1664

    Pierre Lanari
    Keymaster

    This has nothing to do with XMapTools, but it concerns MATLAB and JAVA. It seems that it comes from an incompatibility between MATLAB and your OS (https://de.mathworks.com/matlabcentral/answers/276006-how-to-solve-the-error-exception-in-thread-awt-eventqueue-0-java-lang-illegalargumentexception-c). I recommend you to contact IT office.

    Pierre

    #1872

    Pierre Lanari
    Keymaster

    This specific problem is solved in XMapTools 3.2.1!

    The way the button icons were implemented caused JAVA to crash in a few special configurations. The new way the icons are implemented (from 3.2.1) was tested and seems to be work fine.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.